New lightning, Yak-9, new 4K skins, so much more for IL-2 4.006!

Hot on the heels of patch 4.005 is 4.006 for IL-2: Great Battles and it’s shaping up to be another substantial patch for the series with a lot of great content to look forward to. Today’s developer diary detailed a variety of features and showed us more of what will make the new deferred shading…

IL-2 shows off deferred shading, new pilots, new trailer

When 1CGS mentioned that they were working on a new rendering system using deferred shading, I expected we might see that by the end of the year, however, it looks like their progress on this feature has gone very well so far with the first screenshots coming out showing off the improved reflection system. This…

A look at IL-2’s new effects

Although visual effects are often best seen in motion, I’ve done my best to cover a number of the new effects that have just released this past week with IL-2 series patch 3.006. There are new fire effects, particle effects and debris, and so much more so let’s have a quick look and see if…

nVidia announces RTX 2000 series GPUs and foreshadows the future

After two years of waiting, nVidia has finally announced their new RTX 2000 series graphics cards and it looks like the long wait between generations may have been worth it as today’s announcement shows off some very impressive technology. Plenty of tech sites are covering this in more detail than I can hope to provide…

DCS World 2.5 Beta first impressions

When it was originally announced, the idea was that DCS World 2.5 would transition from beta to a full release and it would do so within a matter of weeks. Almost two months have passed as Eagle Dynamics hammers out some bugs but I couldn’t wait anymore so I’ve jumped straight in to DCS World…

What to do if your DCS World 2.5 doesn’t look right

A lot of users have been commenting in the DCS community that they have installed DCS World 2.5 and it … looks terrible. That’s not how its supposed to be and several users have posted some very helpful tips. I’m reposting them here in-case you need a little help. The problem is your old settings…